Linux

E: Could not perform immediate configuration on ‘util-linux’. Please see man 5 apt

I stole this from the Ubuntu forums (haven’t got link anymore since I just pasted it here very quickly for reference):

I ran into this problem myself, and I’ve seen that others have had the same problem when updating from Karmic to Lucid via apt-get. There is a bug in apt for Lucid, and it has been noted on one of the Ubuntu lists (sorry, I lost the link.)

This is a simple how-to and a work-around to the upgrading with apt-get:

1) Update your sources.list file to replace all instances of ‘karmic” to ‘lucid’ :

$ sudo sed -i ‘s/karmic/lucid/g’ /etc/apt/sources.list

2) Run apt-get update:

$ sudo apt-get update

3) Run a regular upgrade;

$ sudo apt-get upgrade -y

Here is where the problem comes in. Apt is looking for the util-linux package, which is part of upstart-job, but someone apparenlty forgot to write the code to tell apt-about this (whoops!)

So, you now need to install upstart-job by itself. By skipping this step you will get the error message when you try to run step 5: “E: Could not perform immediate configuration on ‘util-linux’.Please see man 5 apt”

4) $ sudo apt-get install upstart-job

5) Now you can run apt-get dist-upgrade:

$ sudo apt-get dist-upgrade -y

Hope this helps out anyone who got stuck.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s